Quantcast

OpenJFX package out-of-date

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

OpenJFX package out-of-date

Kyle Laker
Hello,

The extra/java-openjfx package has been flagged out-of-date since
2016-09-13 and is stuck at verison 8u76-b03. This can result in
runtime warnings for some JavaFX applications whose FXML was created
specifying a newer API version, potentially causing confusion for
users because `java -version` would return the newest version
(1.8.0_121).

The following patch (created using `svn diff`) of the PKGBUILD should
bring it up to match the latest version of extra/jdk8-openjdk. No
changes should be necessary for the gradle.properties file.

Regards,
Kyle


Patch:

Index: PKGBUILD
===================================================================
--- PKGBUILD    (revision 287772)
+++ PKGBUILD    (working copy)
@@ -12,11 +12,11 @@
  pkgbase=java-${_libname}
  pkgname=('java-openjfx' 'java-openjfx-doc' 'java-openjfx-src')
  _java_ver=8
-_jdk_update=76
-_jdk_build=03
+_jdk_update=121
+_jdk_build=13
  _hgtag=${_java_ver}u${_jdk_update}-b${_jdk_build}
  pkgver=${_java_ver}.u${_jdk_update}
-pkgrel=2
+pkgrel=1
  pkgdesc='Java OpenJFX 8 client application platform (open-source
implementation of JavaFX)'
  arch=('i686' 'x86_64')
  url='https://wiki.openjdk.java.net/display/OpenJFX/Main'
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OpenJFX package out-of-date

Guillaume ALAUX
On Mon, Jan 30, 2017 at 8:39 PM, Kyle Laker <[hidden email]> wrote:

>
> Hello,
>
> The extra/java-openjfx package has been flagged out-of-date since
> 2016-09-13 and is stuck at verison 8u76-b03. This can result in
> runtime warnings for some JavaFX applications whose FXML was created
> specifying a newer API version, potentially causing confusion for
> users because `java -version` would return the newest version
> (1.8.0_121).
>
> The following patch (created using `svn diff`) of the PKGBUILD should
> bring it up to match the latest version of extra/jdk8-openjdk. No
> changes should be necessary for the gradle.properties file.
>
> Regards,
> Kyle
>
>
> Patch:
>
> Index: PKGBUILD
> ===================================================================
> --- PKGBUILD    (revision 287772)
> +++ PKGBUILD    (working copy)
> @@ -12,11 +12,11 @@
>  pkgbase=java-${_libname}
>  pkgname=('java-openjfx' 'java-openjfx-doc' 'java-openjfx-src')
>  _java_ver=8
> -_jdk_update=76
> -_jdk_build=03
> +_jdk_update=121
> +_jdk_build=13
>  _hgtag=${_java_ver}u${_jdk_update}-b${_jdk_build}
>  pkgver=${_java_ver}.u${_jdk_update}
> -pkgrel=2
> +pkgrel=1
>  pkgdesc='Java OpenJFX 8 client application platform (open-source
> implementation of JavaFX)'
>  arch=('i686' 'x86_64')
>  url='https://wiki.openjdk.java.net/display/OpenJFX/Main'


Thanks. I will try to make some time this week to update it.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OpenJFX package out-of-date

Guillaume ALAUX
On Mon, Jan 30, 2017 at 10:19 PM, Guillaume ALAUX
<[hidden email]> wrote:

> On Mon, Jan 30, 2017 at 8:39 PM, Kyle Laker <[hidden email]> wrote:
>>
>> Hello,
>>
>> The extra/java-openjfx package has been flagged out-of-date since
>> 2016-09-13 and is stuck at verison 8u76-b03. This can result in
>> runtime warnings for some JavaFX applications whose FXML was created
>> specifying a newer API version, potentially causing confusion for
>> users because `java -version` would return the newest version
>> (1.8.0_121).
>>
>> The following patch (created using `svn diff`) of the PKGBUILD should
>> bring it up to match the latest version of extra/jdk8-openjdk. No
>> changes should be necessary for the gradle.properties file.
>>
>> Regards,
>> Kyle
>>
>>
>> Patch:
>>
>> Index: PKGBUILD
>> ===================================================================
>> --- PKGBUILD    (revision 287772)
>> +++ PKGBUILD    (working copy)
>> @@ -12,11 +12,11 @@
>>  pkgbase=java-${_libname}
>>  pkgname=('java-openjfx' 'java-openjfx-doc' 'java-openjfx-src')
>>  _java_ver=8
>> -_jdk_update=76
>> -_jdk_build=03
>> +_jdk_update=121
>> +_jdk_build=13
>>  _hgtag=${_java_ver}u${_jdk_update}-b${_jdk_build}
>>  pkgver=${_java_ver}.u${_jdk_update}
>> -pkgrel=2
>> +pkgrel=1
>>  pkgdesc='Java OpenJFX 8 client application platform (open-source
>> implementation of JavaFX)'
>>  arch=('i686' 'x86_64')
>>  url='https://wiki.openjdk.java.net/display/OpenJFX/Main'
>
>
> Thanks. I will try to make some time this week to update it.

Ok so I finally managed to get OpenJFX to build.

It was a bit more complicated than the patch you provided [0] [1] [2].
I thought you had tested it but I doubt it as makepkg wouldn't even
download the sources.

[0] https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/java-openjfx&id=512bfaf1653042ce6ead2b5cecdc99942ff25627
[1] https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/java-openjfx&id=e1947ee35f9d15f1cbddef189c027005eada7424
[2] https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/java-openjfx&id=8eb70ae9f14e3c87c5f5b5ed7501307ae8ca218e
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OpenJFX package out-of-date

Kyle Laker
Sorry, I thought I had gotten a successful build in my attempts, but I
apparently was mistaken. I certainly got the sources to download,
though. In any case, I apologize that the patch I provided was
incomplete and not thoroughly tested. I appreciate the work you did to
get a successful update of this package working, and I will be sure to
test more thoroughly in the future. Thanks again!

On Mon, Feb 6, 2017 at 8:23 AM, Guillaume ALAUX <[hidden email]> wrote:

> On Mon, Jan 30, 2017 at 10:19 PM, Guillaume ALAUX
> <[hidden email]> wrote:
>> On Mon, Jan 30, 2017 at 8:39 PM, Kyle Laker <[hidden email]> wrote:
>>>
>>> Hello,
>>>
>>> The extra/java-openjfx package has been flagged out-of-date since
>>> 2016-09-13 and is stuck at verison 8u76-b03. This can result in
>>> runtime warnings for some JavaFX applications whose FXML was created
>>> specifying a newer API version, potentially causing confusion for
>>> users because `java -version` would return the newest version
>>> (1.8.0_121).
>>>
>>> The following patch (created using `svn diff`) of the PKGBUILD should
>>> bring it up to match the latest version of extra/jdk8-openjdk. No
>>> changes should be necessary for the gradle.properties file.
>>>
>>> Regards,
>>> Kyle
>>>
>>>
>>> Patch:
>>>
>>> Index: PKGBUILD
>>> ===================================================================
>>> --- PKGBUILD    (revision 287772)
>>> +++ PKGBUILD    (working copy)
>>> @@ -12,11 +12,11 @@
>>>  pkgbase=java-${_libname}
>>>  pkgname=('java-openjfx' 'java-openjfx-doc' 'java-openjfx-src')
>>>  _java_ver=8
>>> -_jdk_update=76
>>> -_jdk_build=03
>>> +_jdk_update=121
>>> +_jdk_build=13
>>>  _hgtag=${_java_ver}u${_jdk_update}-b${_jdk_build}
>>>  pkgver=${_java_ver}.u${_jdk_update}
>>> -pkgrel=2
>>> +pkgrel=1
>>>  pkgdesc='Java OpenJFX 8 client application platform (open-source
>>> implementation of JavaFX)'
>>>  arch=('i686' 'x86_64')
>>>  url='https://wiki.openjdk.java.net/display/OpenJFX/Main'
>>
>>
>> Thanks. I will try to make some time this week to update it.
>
> Ok so I finally managed to get OpenJFX to build.
>
> It was a bit more complicated than the patch you provided [0] [1] [2].
> I thought you had tested it but I doubt it as makepkg wouldn't even
> download the sources.
>
> [0] https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/java-openjfx&id=512bfaf1653042ce6ead2b5cecdc99942ff25627
> [1] https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/java-openjfx&id=e1947ee35f9d15f1cbddef189c027005eada7424
> [2] https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/java-openjfx&id=8eb70ae9f14e3c87c5f5b5ed7501307ae8ca218e
Loading...