Outdated comments in pacman.conf

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Outdated comments in pacman.conf

Andrey Azarov
Hello!

I found what comments in ls /etc/pacman.conf about signature verification
is out of date:

# By default, pacman accepts packages signed by keys that its local keyring
> # trusts (see pacman-key and its man page), as well as unsigned packages.
> SigLevel    = Required DatabaseOptional
> LocalFileSigLevel = Optional
> #RemoteFileSigLevel = Required


So I propose following changes to make comments consistent with default
settings:

# By default, pacman accepts only packages signed by keys that its local
> keyring trusts (see pacman-key and its man page)
> # The only exclusion is packages from local filesystem, such packages can
> be unsigned
> SigLevel    = Required DatabaseOptional
> LocalFileSigLevel = Optional
> #RemoteFileSigLevel = Required


 I include svn patch in attachments.

With best wishes,
Andrey

correct_default_sign_comment.patch (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Outdated comments in pacman.conf

Allan McRae
On 16/07/17 18:48, Andrey Azarov wrote:
> Hello!
>
> I found what comments in ls /etc/pacman.conf about signature verification
> is out of date:
>

This is the copy of pacman.conf provided by Arch Linux, and not the
version in the pacman development repository.  We only handle bugs for
the latter in this list.  File a bug report in the Arch Linux bug
tracker against the pacman package.

Allan
Loading...