Quantcast

Xorg-server 1.14 hitting testing

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Xorg-server 1.14 hitting testing

Andreas Radke-2
Following drivers need further fixing and are not yet rebuilt:

xf86-video-sis:

sis_driver.c:9384:13: error: too few arguments to function
'miPointerSetPosition' In file included
from /usr/include/xorg/xf86Cursor.h:6:0, from sis.h:83,
                 from sis_driver.c:50:
/usr/include/xorg/mipointer.h:118:1: note: declared here

This is due to changes in Xinput 2.3 in /usr/include/xorg/mipointer.h
changes from

miPointerSetPosition(DeviceIntPtr pDev, int mode, double *x, double *y);

to

miPointerSetPosition(DeviceIntPtr pDev, int mode, double *x, double *y,
                     int *nevents, InternalEvent *events);


similar for sisimedia and sisusb drivers.

Current NVidia blob driver + NVidia-304 series claims to be ready for
new Xorg. No idea about catalyst.

Happy testing and upstream bug reporting.

-Andy

signature.asc (501 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Laurent Carlier
Le samedi 9 mars 2013 19:06:29 Andreas Radke a écrit :

> Following drivers need further fixing and are not yet rebuilt:
>
> xf86-video-sis:
>
> sis_driver.c:9384:13: error: too few arguments to function
> 'miPointerSetPosition' In file included
> from /usr/include/xorg/xf86Cursor.h:6:0, from sis.h:83,
>                  from sis_driver.c:50:
> /usr/include/xorg/mipointer.h:118:1: note: declared here
>
> This is due to changes in Xinput 2.3 in /usr/include/xorg/mipointer.h
> changes from
>
> miPointerSetPosition(DeviceIntPtr pDev, int mode, double *x, double *y);
>
> to
>
> miPointerSetPosition(DeviceIntPtr pDev, int mode, double *x, double *y,
>                      int *nevents, InternalEvent *events);
>
>
> similar for sisimedia and sisusb drivers.
>
> Current NVidia blob driver + NVidia-304 series claims to be ready for
> new Xorg. No idea about catalyst.
>
> Happy testing and upstream bug reporting.
>
> -Andy
Catalyst doesn't support Xorg-server 1.14.

++

signature.asc (501 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Pierre Schmitz
Am 09.03.2013 22:14, schrieb Laurent Carlier:

> Le samedi 9 mars 2013 19:06:29 Andreas Radke a écrit :
>> Following drivers need further fixing and are not yet rebuilt:
>> ...
>> Current NVidia blob driver + NVidia-304 series claims to be ready for
>> new Xorg. No idea about catalyst.
>>
>> Happy testing and upstream bug reporting.
>>
>> -Andy
>
> Catalyst doesn't support Xorg-server 1.14.

This was one of the reasons why catalyst was dropped from the repos
some time ago:
https://www.archlinux.org/news/ati-catalyst-support-dropped/

--
Pierre Schmitz, https://pierre-schmitz.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Laurent Carlier
Le dimanche 10 mars 2013 02:57:31 Pierre Schmitz a écrit :

> Am 09.03.2013 22:14, schrieb Laurent Carlier:
> > Le samedi 9 mars 2013 19:06:29 Andreas Radke a écrit :
> >> Following drivers need further fixing and are not yet rebuilt:
> >> ...
> >> Current NVidia blob driver + NVidia-304 series claims to be ready for
> >> new Xorg. No idea about catalyst.
> >>
> >> Happy testing and upstream bug reporting.
> >>
> >> -Andy
> >
> > Catalyst doesn't support Xorg-server 1.14.
>
> This was one of the reasons why catalyst was dropped from the repos
> some time ago:
> https://www.archlinux.org/news/ati-catalyst-support-dropped/
Users will have to wait until a compatible version is available. Mesa drivers
are an alternative, or they can block the upgrade.

++

signature.asc (501 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Andreas Radke-2
In reply to this post by Andreas Radke-2
SIS* drivers are rebuilt and also in testing.

-Andy

signature.asc (501 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Andreas Radke-2
In reply to this post by Laurent Carlier
Am Sun, 10 Mar 2013 09:27:16 +0100
schrieb Laurent Carlier <[hidden email]>:

> Users will have to wait until a compatible version is available. Mesa
> drivers are an alternative, or they can block the upgrade.
>
> ++

I'd like to move Xorg 1.14 pretty soon, best would be together with
the kernels. It's up to you whether you want to announce to hold the
update for catalyst users or remove it from the repos.

I suggest to use the video api dependency + conflicts like we do in all
other driver packages to avoid the xorg-server update for catalyst
users. But this is your choice.

-Andy

signature.asc (501 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Pierre Schmitz
Am 16.03.2013 10:05, schrieb Andreas Radke:
> I'd like to move Xorg 1.14 pretty soon, best would be together with
> the kernels. It's up to you whether you want to announce to hold the
> update for catalyst users or remove it from the repos.

I just noticed that Virtualbox does not work with the latest
xorg-server due to ABI mismatch. Is this known? It's possible that
rebuildig the driver might fix this.

--
Pierre Schmitz, https://pierre-schmitz.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Ionut Biru-2
On 03/16/2013 12:09 PM, Pierre Schmitz wrote:
> Am 16.03.2013 10:05, schrieb Andreas Radke:
>> I'd like to move Xorg 1.14 pretty soon, best would be together with
>> the kernels. It's up to you whether you want to announce to hold the
>> update for catalyst users or remove it from the repos.
>
> I just noticed that Virtualbox does not work with the latest
> xorg-server due to ABI mismatch. Is this known? It's possible that
> rebuildig the driver might fix this.
>

i'll take a look later today at this.

--
Ionuț


signature.asc (567 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Laurent Carlier
In reply to this post by Andreas Radke-2
Le samedi 16 mars 2013 10:05:54 Andreas Radke a écrit :

> Am Sun, 10 Mar 2013 09:27:16 +0100
>
> schrieb Laurent Carlier <[hidden email]>:
> > Users will have to wait until a compatible version is available. Mesa
> > drivers are an alternative, or they can block the upgrade.
> >
> > ++
>
> I'd like to move Xorg 1.14 pretty soon, best would be together with
> the kernels. It's up to you whether you want to announce to hold the
> update for catalyst users or remove it from the repos.
>
> I suggest to use the video api dependency + conflicts like we do in all
> other driver packages to avoid the xorg-server update for catalyst
> users. But this is your choice.
>
> -Andy
This was my first choice, to block updates through api dependency until an api
compatible driver (packages will follow today in community-testing).

So what is the best choice (final vote):
* keep it and block update
* remove it

For both choices, there is mesa as an alternative.

++

signature.asc (501 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Sven-Hendrik Haase
On 16.03.2013 17:48, Laurent Carlier wrote:

> Le samedi 16 mars 2013 10:05:54 Andreas Radke a écrit :
>> Am Sun, 10 Mar 2013 09:27:16 +0100
>>
>> schrieb Laurent Carlier <[hidden email]>:
>>> Users will have to wait until a compatible version is available. Mesa
>>> drivers are an alternative, or they can block the upgrade.
>>>
>>> ++
>> I'd like to move Xorg 1.14 pretty soon, best would be together with
>> the kernels. It's up to you whether you want to announce to hold the
>> update for catalyst users or remove it from the repos.
>>
>> I suggest to use the video api dependency + conflicts like we do in all
>> other driver packages to avoid the xorg-server update for catalyst
>> users. But this is your choice.
>>
>> -Andy
> This was my first choice, to block updates through api dependency until an api
> compatible driver (packages will follow today in community-testing).
>
> So what is the best choice (final vote):
> * keep it and block update
> * remove it
>
> For both choices, there is mesa as an alternative.
>
> ++
I'd keep it for now and block update. AMD has been better the last 2
years. Maybe they'll follow up on this problem soon enough?


signature.asc (853 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Andreas Radke-2
Am Sun, 17 Mar 2013 04:55:01 +0100
schrieb Sven-Hendrik Haase <[hidden email]>:

>
> I'd keep it for now and block update. AMD has been better the last 2
> years. Maybe they'll follow up on this problem soon enough?
>

There's already a beta driver out with 1.14 support ;)

But I don't want to wait until they will release it as final.

-Andy

signature.asc (501 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Laurent Carlier
Le dimanche 17 mars 2013 09:53:57 Andreas Radke a écrit :

> Am Sun, 17 Mar 2013 04:55:01 +0100
>
> schrieb Sven-Hendrik Haase <[hidden email]>:
> > I'd keep it for now and block update. AMD has been better the last 2
> > years. Maybe they'll follow up on this problem soon enough?
>
> There's already a beta driver out with 1.14 support ;)
>
> But I don't want to wait until they will release it as final.
>
> -Andy
You can move it in "stable", catalyst-utils in community won't let you upgrade
xorg-server to 1.14

++

signature.asc (501 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Pierre Schmitz
In reply to this post by Pierre Schmitz
Am 16.03.2013 11:09, schrieb Pierre Schmitz:
> Am 16.03.2013 10:05, schrieb Andreas Radke:
>> I'd like to move Xorg 1.14 pretty soon, best would be together with
>> the kernels. It's up to you whether you want to announce to hold the
>> update for catalyst users or remove it from the repos.
>
> I just noticed that Virtualbox does not work with the latest
> xorg-server due to ABI mismatch. Is this known? It's possible that
> rebuildig the driver might fix this.

Why was this moved to extra regardless of the known issues it causes?

--
Pierre Schmitz, https://pierre-schmitz.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Andreas Radke-2
Am Tue, 19 Mar 2013 19:18:49 +0100
schrieb Pierre Schmitz <[hidden email]>:

> Am 16.03.2013 11:09, schrieb Pierre Schmitz:
> > Am 16.03.2013 10:05, schrieb Andreas Radke:
> >> I'd like to move Xorg 1.14 pretty soon, best would be together with
> >> the kernels. It's up to you whether you want to announce to hold
> >> the update for catalyst users or remove it from the repos.
> >
> > I just noticed that Virtualbox does not work with the latest
> > xorg-server due to ABI mismatch. Is this known? It's possible that
> > rebuildig the driver might fix this.
>
> Why was this moved to extra regardless of the known issues it causes?
>
The kernel got moved and no stopper for Xorg was known. We don't care
about catalyst, vmware is broken upstream and this is known for months,
for vbox there's no bug report expect your late mail and there's a
workaround to ignore the ABI mismatch.

So far this is a calm move.

-Andy

signature.asc (501 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg-server 1.14 hitting testing

Ionut Biru-2
In reply to this post by Pierre Schmitz
On 03/19/2013 08:18 PM, Pierre Schmitz wrote:

> Am 16.03.2013 11:09, schrieb Pierre Schmitz:
>> Am 16.03.2013 10:05, schrieb Andreas Radke:
>>> I'd like to move Xorg 1.14 pretty soon, best would be together with
>>> the kernels. It's up to you whether you want to announce to hold the
>>> update for catalyst users or remove it from the repos.
>>
>> I just noticed that Virtualbox does not work with the latest
>> xorg-server due to ABI mismatch. Is this known? It's possible that
>> rebuildig the driver might fix this.
>
> Why was this moved to extra regardless of the known issues it causes?
>
i'm building it right now. I didn't even know that xorg-server was moved...

--
Ionuț


signature.asc (567 bytes) Download Attachment
Loading...