arch-audit didn't survive the openssl upgrade to 1.1.0

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

arch-audit didn't survive the openssl upgrade to 1.1.0

Ricardo Band-2
Ahoi,

arch-audit in version 0.1.8-2 still looks for openssl 1.0.0:

    arch-audit: error while loading shared libraries: libssl.so.1.0.0:
cannot open shared object file: No such file or directory

After installing openssl-1.0 it works again.

I see 2 solutions here. Update arch-audit to use OpenSSL 1.1 or add
openssl-1.0 as a dependency to arch-audit package.

--

Greetings

Ricardo Band

 https://   www.ricardo.band
mailto:// [hidden email]

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: arch-audit didn't survive the openssl upgrade to 1.1.0

Jelle van der Waa-2
On 04/27/17 at 03:46pm, Ricardo Band wrote:

> Ahoi,
>
> arch-audit in version 0.1.8-2 still looks for openssl 1.0.0:
>
>     arch-audit: error while loading shared libraries: libssl.so.1.0.0:
> cannot open shared object file: No such file or directory
>
> After installing openssl-1.0 it works again.
>
> I see 2 solutions here. Update arch-audit to use OpenSSL 1.1 or add
> openssl-1.0 as a dependency to arch-audit package.
For these issues we have a bugtracker on https://bugs.archlinux.org

--
Jelle van der Waa

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: arch-audit didn't survive the openssl upgrade to 1.1.0

Christian Rebischke-2
In reply to this post by Ricardo Band-2
On Thu, Apr 27, 2017 at 03:46:31PM +0200, Ricardo Band wrote:

> Ahoi,
>
> arch-audit in version 0.1.8-2 still looks for openssl 1.0.0:
>
>     arch-audit: error while loading shared libraries: libssl.so.1.0.0:
> cannot open shared object file: No such file or directory
>
> After installing openssl-1.0 it works again.
>
> I see 2 solutions here. Update arch-audit to use OpenSSL 1.1 or add
> openssl-1.0 as a dependency to arch-audit package.

Thanks,
I will have a look at it and rebuild arch-audit today. Expect the next
release in some hours :)

chris

signature.asc (849 bytes) Download Attachment
Loading...