freecad maintainer wanted

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

freecad maintainer wanted

arch dev mailing list
Hi,

Since I no longer use freecad myself I am not very interested in
continuing to maintain it. If nobody steps up, I will move it to AUR in
about a week.

Some notes:
 - The current release is over a year old, a new one should come
   soonish.
 - There is an open bug[1] that leads me to believe that freecad might
   use a bundeled version of coin3d which contains a bundeled version of
   expat that is very old and may also contain security
   vulnerabilities.
 - I haven't yet managed to build freecad from git master with qt5
   support. Looks like it needs pyside2 for this, but that doesn't have
   a stable release and we don't pacakge random commits from a git
   branch.
 - freecad 0.16 (current version) blocks opencascade from being updated
   to >= 7.0. 0.17 should be compatible at least with 7.0, possibly with
   7.1.

[1] https://bugs.archlinux.org/task/57843

Florian

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: freecad maintainer wanted

arch dev mailing list
On 15.03.2018 11:24, Florian Pritz via arch-dev-public wrote:
> Since I no longer use freecad myself I am not very interested in
> continuing to maintain it. If nobody steps up, I will move it to AUR in
> about a week.

Moved freecad, opencascade, python2-pivy, python-pyside-tools, soqt,
coin, vtk6.

Orphaned shiboken, python-pyside.

Florian


signature.asc (875 bytes) Download Attachment