initi issue

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

initi issue

Frank Zimmermann
Good evening,

I'm having troubles booting my laptop. I do get the following error:
Failed to execute /init (error -2)
Kernel panic - not syncing: No working init found. TRy passing init=
option to kernel
CPU: 3 PID: 1 Comm: swapper/0 Not tainted 4.10.2-1-ARCH #1
Call trace:
dump_stack+0x63/0x83
? csum_partial_copy_generic+0x170/0x170
panic+0xe/0x22d
? putname+0x54/0x60
? rest_init+0x90/0x90
kernel_init+0xeb/0x100
ret_from_fork+0x2c/0x40
Kernel Offset: disabled

I've booted from archiso and chrooted in the system, tried to reinstall
kernel, did an upgrade, made ne initrd and reinstalled grub without any
success.
THX Frank
Reply | Threaded
Open this post in threaded view
|

Re: initi issue

arch general mailing list-2
Hi Frank, you try with this:

1. Boot archiso and chrooted in the system.

2. Mount your boot partition

- In my case it is: mount /dev/sda1 /boot

3. Run mkinitcpio

- In my case it is: mkinitcpio -p linux-lts


Rado


On 05/04/17 19:22, Frank wrote:

> Good evening,
>
> I'm having troubles booting my laptop. I do get the following error:
> Failed to execute /init (error -2)
> Kernel panic - not syncing: No working init found. TRy passing init=
> option to kernel
> CPU: 3 PID: 1 Comm: swapper/0 Not tainted 4.10.2-1-ARCH #1
> Call trace:
> dump_stack+0x63/0x83
> ? csum_partial_copy_generic+0x170/0x170
> panic+0xe/0x22d
> ? putname+0x54/0x60
> ? rest_init+0x90/0x90
> kernel_init+0xeb/0x100
> ret_from_fork+0x2c/0x40
> Kernel Offset: disabled
>
> I've booted from archiso and chrooted in the system, tried to reinstall
> kernel, did an upgrade, made ne initrd and reinstalled grub without any
> success.
> THX Frank
Reply | Threaded
Open this post in threaded view
|

Re: initi issue

arch general mailing list-2
In reply to this post by Frank Zimmermann
You should make sure you have:
- systemd-sysvcompat installed properly
Another way which I'm using (since I consider that package silly) is this:
- add init=/usr/lib/systemd/systemd to GRUB_CMDLINE_LINUX in
/etc/default/grub and run grub-mkconfig -o /boot/grub/grub.cfg -- or
the according action using your bootloader.

Your system basically doesn't know what to run as pid 1.

cheers!
mar77i
Reply | Threaded
Open this post in threaded view
|

Re: initi issue

Ralf Mardorf-4
In reply to this post by Frank Zimmermann
On Wed, 5 Apr 2017 20:22:07 +0200, Frank wrote:

>Good evening,
>
>I'm having troubles booting my laptop. I do get the following error:
>Failed to execute /init (error -2)
>Kernel panic - not syncing: No working init found. TRy passing init=
>option to kernel
>CPU: 3 PID: 1 Comm: swapper/0 Not tainted 4.10.2-1-ARCH #1
>Call trace:
>dump_stack+0x63/0x83
>? csum_partial_copy_generic+0x170/0x170
>panic+0xe/0x22d
>? putname+0x54/0x60
>? rest_init+0x90/0x90
>kernel_init+0xeb/0x100
>ret_from_fork+0x2c/0x40
>Kernel Offset: disabled
>
>I've booted from archiso and chrooted in the system, tried to reinstall
>kernel, did an upgrade, made ne initrd and reinstalled grub without any
>success.
>THX Frank

When did that happen? After an update? If so I would tend to downgrade,
e.g.
https://www.archlinux.org/packages/core/x86_64/linux-lts/
https://aur.archlinux.org/packages/downgrade/
Did you try anything else?
E.g. https://bbs.archlinux.org/viewtopic.php?id=162704
or any of the other [solved] threads
https://www.google.de/?gws_rd=ssl#q=Kernel+panic+-+not+syncing:+No+working+init+found.&*
?
Reply | Threaded
Open this post in threaded view
|

Re: initi issue

Frank Zimmermann
Am Mittwoch, den 05.04.2017, 20:56 +0200 schrieb Ralf Mardorf:
>
> Did you try anything else?
> E.g. https://bbs.archlinux.org/viewtopic.php?id=162704

Thanks,

this hint to broken filesystem package did the job.

KR Frank