libflashsupport and gflashplayer

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

libflashsupport and gflashplayer

Roman Kyrylych
Hi!

A quote from http://bugs.archlinux.org/task/5679:
"After some thought, I decided to create a new package for this:
libflashsupport. This depends on flashplugin-beta, icu, and openssl.
This puts the deps of a 4KB package at about 9MB. ;)
Installing libflashsupport will enable internationalization, ssl
support, and multiple audio outputs"

But libflashsupport is for flashplugin only. What about standalone
gflashplayer? As I see it depends only on gtk2, so I suppose it don't
have functions provided by libflashsupport, right?

--
Roman Kyrylych (Роман Кирилич)
_______________________________________________
arch mailing list
[hidden email]
http://www.archlinux.org/mailman/listinfo/arch
Reply | Threaded
Open this post in threaded view
|

Re: libflashsupport and gflashplayer

Woody Gilk
Roman Kyrylych wrote:
> But libflashsupport is for flashplugin only. What about standalone
> gflashplayer? As I see it depends only on gtk2, so I suppose it don't
> have functions provided by libflashsupport, right
I believe you are correct. Adobe's page on this (
http://labs.adobe.com/wiki/index.php/Flash_Player:Additional_Interface_Support_for_Linux
) doesn't mention anything about the stand alone player. I believe
libflashsupport only effects the actual player plugin.

-Woody

_______________________________________________
arch mailing list
[hidden email]
http://www.archlinux.org/mailman/listinfo/arch
Reply | Threaded
Open this post in threaded view
|

Re: libflashsupport and gflashplayer

Yonathan Dossow-2
In reply to this post by Roman Kyrylych
On Thu, Nov 02, 2006 at 11:49:56AM +0200, Roman Kyrylych wrote:

> Hi!
>
> A quote from http://bugs.archlinux.org/task/5679:
> "After some thought, I decided to create a new package for this:
> libflashsupport. This depends on flashplugin-beta, icu, and openssl.
> This puts the deps of a 4KB package at about 9MB. ;)
> Installing libflashsupport will enable internationalization, ssl
> support, and multiple audio outputs"
>
> But libflashsupport is for flashplugin only. What about standalone
> gflashplayer? As I see it depends only on gtk2, so I suppose it don't
> have functions provided by libflashsupport, right?
libflashsupport adds HTTPS and RTMPS URL support in the stand-alone
player.

--
Yonathan H. Dossow Acun~a                      http://kronin.bla.cl
Estudiante Ingenieria Civil Informatica
Universidad Tecnica Federico Santa Maria          Valparaiso, Chile

_______________________________________________
arch mailing list
[hidden email]
http://www.archlinux.org/mailman/listinfo/arch

attachment0 (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: libflashsupport and gflashplayer

Roman Kyrylych
2006/11/3, Yonathan Dossow <[hidden email]>:
> libflashsupport adds HTTPS and RTMPS URL support in the stand-alone
> player.

Then there should be separate package for libflashsupport for
gflashplayer, or better make gflashplayer and flashplugin provide
'flash' and make libflashsupport package compatible with both
(currently it installs in /opt/mozilla which is not good for
gflashplayer).

--
Roman Kyrylych (Роман Кирилич)
_______________________________________________
arch mailing list
[hidden email]
http://www.archlinux.org/mailman/listinfo/arch
Reply | Threaded
Open this post in threaded view
|

Re: libflashsupport and gflashplayer

Woody Gilk
Roman Kyrylych wrote:
> Then there should be separate package for libflashsupport for
> gflashplayer, or better make gflashplayer and flashplugin provide
> 'flash' and make libflashsupport package compatible with both
> (currently it installs in /opt/mozilla which is not good for
> gflashplayer).
>  
I already fixed that, it installs to /usr/lib now.

_______________________________________________
arch mailing list
[hidden email]
http://www.archlinux.org/mailman/listinfo/arch
Reply | Threaded
Open this post in threaded view
|

Re: libflashsupport and gflashplayer

Roman Kyrylych
2006/11/3, Woody Gilk <[hidden email]>:
> Roman Kyrylych wrote:
> > Then there should be separate package for libflashsupport for
> > gflashplayer, or better make gflashplayer and flashplugin provide
> > 'flash' and make libflashsupport package compatible with both
> > (currently it installs in /opt/mozilla which is not good for
> > gflashplayer).
> >
> I already fixed that, it installs to /usr/lib now.

Good. So now I suppose it can be chanded to depend on 'flash' provided
by both flashplugin and gflashplayer. ;)

--
Roman Kyrylych (Роман Кирилич)
_______________________________________________
arch mailing list
[hidden email]
http://www.archlinux.org/mailman/listinfo/arch