patch for hypre package

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

patch for hypre package

Wink Saville
I needed to update the the hypre package,
https://aur.archlinux.org/packages/hypre/, as the PKGBUILD does not work in
its current state, version 2.11.0 is no longer available. I created the
following patch which allowed me to compile and install. What is the
procedure for submitting a patch?

$ cat diff-2.11.2.patch
diff --git a/.SRCINFO b/.SRCINFO
index 5e5609d..4f9d4b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
 # Typed up manually
 pkgbase = hypre
  pkgdesc = A library for solving large, sparse linear systems on massively
parallel computers
- pkgver = 2.11.0
+ pkgver = 2.11.2
  pkgrel = 1
  url = http://acts.nersc.gov/hypre
  arch = i686
@@ -13,8 +13,8 @@ pkgbase = hypre
  depends = blas
  depends = lapack
  depends = superlu
- source =
http://computation.llnl.gov/project/linear_solvers/download/v2.11.0.tar.gz
- md5sums = aeba702e1b6c6e9f7b7627e56c51ca69
+ source =
https://computation.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods/download/hypre-2.11.2.tar.gz
+ md5sums = d507943a1a3ce5681c3308e2f3a6dd34

 pkgname = hypre

diff --git a/PKGBUILD b/PKGBUILD
index 30e812e..c26e6bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,22 @@
 # Maintainer: Alessandro G. Magnasco <alessandromagnasco at gmail dot com>
 # Contributor: Bertrand Lacoste <bertrandlacoste at gmail dot com>
 # Contributor: Tim Langlois <langlois at cs dot cornell dot edu>
+# Contributor: Wink Saville <wink at saville dot com>

 pkgname=hypre
-pkgver=2.11.0
-_suffix='babel'
-## Use the source from petsc website, suffixed by _p1. Also change the
source and checksums.
-#_suffix='p1'
+pkgver=2.11.2
+_suffix=
 pkgrel=1
 pkgdesc="A library for solving large, sparse linear systems on massively
parallel computers"
 arch=('i686' 'x86_64')
 url="http://acts.nersc.gov/hypre"
 license=('lgpl')
 depends=('gcc-libs' 'gcc-fortran' 'openmpi' 'blas' 'lapack' 'superlu')
-#OLD SOURCE source=(
http://computation.llnl.gov/project/linear_solvers/download/${pkgname}-${pkgver}-${_suffix}.tar.gz
)
-source=(
http://computation.llnl.gov/project/linear_solvers/download/v${pkgver}.tar.gz
)
-md5sums=('aeba702e1b6c6e9f7b7627e56c51ca69')
-
-# MIRROR -- OLD (NOT UP YET)
-# source=(
http://ftp.mcs.anl.gov/pub/petsc/externalpackages/hypre-2.10.0b-p1.tar.gz)
-# md5sums=('7aa49089176c8bef7f51a0234264f952')
+source=(
https://computation.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods/download/hypre-${pkgver}.tar.gz
)
+md5sums=('d507943a1a3ce5681c3308e2f3a6dd34')

 build() {
-  _build_dir="${srcdir}/${pkgname}-${pkgver}-${_suffix}"
+  _build_dir="${srcdir}/${pkgname}-${pkgver}${_suffix}"
   cd "${_build_dir}/src"


@@ -42,14 +36,14 @@ build() {
 }

 check() {
-  _build_dir="${srcdir}/${pkgname}-${pkgver}-${_suffix}"
+  _build_dir="${srcdir}/${pkgname}-${pkgver}${_suffix}"
   cd "${_build_dir}/src"

   make test
 }

 package() {
-  _build_dir="${srcdir}/${pkgname}-${pkgver}-${_suffix}"
+  _build_dir="${srcdir}/${pkgname}-${pkgver}${_suffix}"
   cd "${_build_dir}/src"

   mkdir -p ${pkgdir}/usr/lib ${pkgdir}/usr/include
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: patch for hypre package

tur-users mailing list
On Fri, Aug 11, 2017 at 7:49 PM, Wink Saville <[hidden email]> wrote:

> I needed to update the the hypre package,
> https://aur.archlinux.org/packages/hypre/, as the PKGBUILD does not work
> in
> its current state, version 2.11.0 is no longer available. I created the
> following patch which allowed me to compile and install. What is the
> procedure for submitting a patch?
>

You could leave a comment on its AUR page with a link to the patch (eg.
using https:/pb.gehidore.net/f ). It's been flagged out-of-date for 8
months; submit an orphan request if you'd like to maintain it.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: patch for hypre package

Wink Saville
I left a comment with my patch for now.

On Fri, Aug 11, 2017, 7:24 PM Daniel Capella via aur-general <
[hidden email]> wrote:

> On Fri, Aug 11, 2017 at 7:49 PM, Wink Saville <[hidden email]> wrote:
>
> > I needed to update the the hypre package,
> > https://aur.archlinux.org/packages/hypre/, as the PKGBUILD does not work
> > in
> > its current state, version 2.11.0 is no longer available. I created the
> > following patch which allowed me to compile and install. What is the
> > procedure for submitting a patch?
> >
>
> You could leave a comment on its AUR page with a link to the patch (eg.
> using https:/pb.gehidore.net/f ). It's been flagged out-of-date for 8
> months; submit an orphan request if you'd like to maintain it.
>
Loading...